The operation could not be completed because item was removed from the gallery

This is common Webpart deployment error

Some time after deploying the wsp package containing webpart doesnot work properly.

When tried to add into the webpart it throws error:-

 The operation could not be completed because item was removed from the gallery

 To solve this problem go to webpart gallery delete the webpartentry from the gallery and then deactivate and activate the webpart feature.

 

Advertisements

3 thoughts on “The operation could not be completed because item was removed from the gallery

  1. you can navigate to Webpart gallery from site settings.
    Click Site Actions -> Site Settings
    Then under “Galleries” section click “Web Parts”

    http://Your SIte Name/_catalogs/wp/Forms/AllItems.aspx

  2. The error correctly (in my case) that the web part has been removed from the gallery, so I can’t remove it from the gallery, it’s already not there. Yet they still appear on the list of custom web parts that can be added, except they can’t. This is ridiculous although I can’t say I’m surprised. Thanks again Microsoft.

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s